Turn signals no working - Toyota Sienna Forum - siennachat.com
 
LinkBack Thread Tools
post #1 of 11 (permalink) Old 12-01-2009, 09:06 AM Thread Starter
ray
Junior Member
 
Join Date: Mar 2009
Posts: 83
Turn signals no working

The turn signals as well as the hazzards quite working in my 98 Sienna. The bulbs do light up but no turn signals. Could it be the flasher or could it be a relay?
ray is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 12-01-2009, 09:33 AM
Supporting Member
 
Join Date: Sep 2009
Posts: 32
Re: Turn signals no working

Maybe the flasher module? I've never switched one out before but I think it's around the fuse box and marked "flasher" or something like that.

The headlights on my Sienna went out last month (only the brights worked). It ended up being the entire stalk. The contacts were burnt out. It cost me $150 to fix.
Michael9 is offline  
post #3 of 11 (permalink) Old 12-01-2009, 09:57 PM
Supporting Member
 
Join Date: Feb 2009
Posts: 1,316
Re: Turn signals no working

I am going with the flasher . Located left side of the steering column. In most cases you can turn the signal on and off several times to find the relay as it will click as you turn on the signals. Remove the relay and give it a shake. You will probally hear something rattling around inside. That will be the contact that broke. Both my old buddys vans had this problem

2004 CE
AIR LIFT '1000'
OVERHEAD 'DEALER' DVD
'HITCH CITY' 2' HITCH
Support 'SIENNACHAT' HERE

Best Auto Insurance | Auto Protection Today | FREE Trade-In Quote
robo5 is offline  
 
post #4 of 11 (permalink) Old 12-05-2009, 11:37 AM Thread Starter
ray
Junior Member
 
Join Date: Mar 2009
Posts: 83
Re: Turn signals no working

Well I replaced the flasher and still nothing ... There are some relays in the fuse box in the engine compartment but the owner's manual doesn't show which are what. All fuses are fine and everything else is working fine.

I also checked the hazards switch and it's fine but still no turn signals.

Any ideas?
ray is offline  
post #5 of 11 (permalink) Old 12-15-2009, 10:05 AM Thread Starter
ray
Junior Member
 
Join Date: Mar 2009
Posts: 83
Re: Turn signals no working

any other ideas?
ray is offline  
post #6 of 11 (permalink) Old 12-29-2009, 11:06 AM Thread Starter
ray
Junior Member
 
Join Date: Mar 2009
Posts: 83
Re: Turn signals no working

bump
ray is offline  
post #7 of 11 (permalink) Old 01-05-2010, 08:32 AM Thread Starter
ray
Junior Member
 
Join Date: Mar 2009
Posts: 83
Re: Turn signals no working

Well finally took the van to the dealer, service advisor calls me and tells me there's a bad relay/flasher under the dash that needs replacing for $140.00. How many relays do these vans have.

ray is offline  
post #8 of 11 (permalink) Old 12-25-2015, 12:36 PM
Junior Member
 
Join Date: Dec 2011
Posts: 1
Re: Turn signals no working

I checked both fuses, under the hood and below steering wheel. Both were fine, the problem was with the replay. The relay is behind the coin tray/fuse panel. No need to remove anything. Look from underneath and access from underneath. The relay is on tightly, but it can be wiggle out with your hand. I replaced with a non-OEM Tridon (Novita Tech) EP35 flasher. It fits nicely like the OEM relay. It works good so far, also works with LED bulbs too.
ping75 is offline  
post #9 of 11 (permalink) Old 10-28-2016, 06:30 PM
Junior Member
 
Join Date: Aug 2016
Location: Mississauga, Ontario, Canada
Posts: 9
Re: Turn signals no working

Well like a dumba** i installed LED Signals thinking it would work, turned them on, no hazards or turn signals, looked at the drivers side junction box, found that the taillight fuse had blown, bought an 8 pin LED flasher (cause mine is a 2007 XLE). Installed it and it still didn't work. Went over to the Tacoma forum, some guys says its the horn fuse in the engine junction box, my horn fuse was fine. Called an automotive electrician. Found that the Hazard fuse in the engine compartment had blown as well. I guess it pays to learn.

2004 Sienna XLE FWD - SOLD
2014 Corolla S - Mother's Car

2007 Sienna XLE FWD (Imported From USA) Gen 3 Front Brake Upgrade
Clarion NX404 Head Unit
JBL Turn On Amplifier Module
LED Reverse Lights
Full LED Interior
LED Fog Lights
DAI ART Replica 97 - 8"Rims On Khumo Tires 245/50/18
alex150 is offline  
post #10 of 11 (permalink) Old 10-29-2016, 12:20 PM
iRt
Member
 
Join Date: Oct 2015
Posts: 224
Re: Turn signals no working

Why didn't the LED bulbs work?
iRt is offline  
post #11 of 11 (permalink) Old 12-14-2016, 05:34 AM
Junior Member
 
Join Date: Jan 2016
Posts: 31
Re: Turn signals no working

Some vehicles have separate flasher relays for turn signals and hazard lights. Be sure to check both systems while you're thinking about signal relays. Hazard lights can be very important.
BrianEtemad is offline  
Reply

Tags
signals, turn, working

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Toyota Sienna Forum - siennachat.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome