Toyota Sienna Forum - siennachat.com banner
1 - 4 of 4 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Bought 2008 Sienna van Le model weeks ago . Getting poor radio reception or static all channels. Radio stopped working once . Removed radio and checked radio connections. Read a blog that changing Antenna Base wiring would help or fix it . Changed that and has new antenna pole or whip snapped off when changing it . Ground contact looked clean . Thought maybe adding external ground wire to the radio, Still same condition. Any thought or fixes. Wife needs her radio !
thanks
Mark
Ontario, Canada
 

· Registered
2008 Toyota Sienna XLE awd
Joined
·
64 Posts
reviving an un answered thread as my radio is now experiencing the same symptoms. I only listen to AM talk shows and it is frustrating when your radio works great and you drive distance listening and then for no apparent reason it goes low volume with background fuzz. I did see a video where someone lowered the DVD player off the ceiling to unplug the antennae from it and that seems to have cured the problem but I have not tried that yet.
 

· Registered
Joined
·
368 Posts
The symptoms you describe sound like a bad antenna connection. That's the first thing I would investigate. If the antenna and cable seem to be OK, it's probably an internal problem with the radio. I have an old truck that experienced total radio failure 1½ years ago. AM and FM were dead but the tape player and line in still worked. I thought the antenna had failed. It checked out as OK. It was the radio that had failed. I bought a new receiver/CD unit from Crutchfield and have been quite happy with it. It sounds better than the OEM radio did when the truck was new. Crutchfield provided a wiring harness adapter and new trim for the dashboard to accommodate the new unit in my 30+ year old truck.
 

· Registered
2008 Toyota Sienna XLE awd
Joined
·
64 Posts
Hmmmmmn I did just have the cd player replaced but it was a couple months back and everything worked well. This latest conundrum is just the radio and I will see if un plugging from the ceiling does anything or not. Just have to get some time to try it. I have never had any problem with reception for the radio in any of my many cars , so this is a first event for me.
 
1 - 4 of 4 Posts
Top