Toyota Sienna Forum - siennachat.com banner

1 - 8 of 8 Posts

·
Registered
Joined
·
152 Posts
Discussion Starter #1
This is weird...

Today, the HVAC display in the center of the dash stopped showing the temp setting and information for the front cabin AC. Then it froze at 70. The temp selector (spinner on dash) is non functional. Neither the driver side nor the passenger side controls work. Mode, fan speed does not work. RECIRC does work. Shutdown several times but no change. Restarted several times, no change.

Fan is working but stuck on low speed. Compressor works and cycles. Rear unit works correctly and displays correctly.

I grabbed the manual and checked all the fuses related to AC, heater, etc. All appear to be OK on first look.

Any insight or experience is appreciated.
 

·
Super Moderator
Joined
·
5,018 Posts
On the Gen-II the AC Amplifier was behind the front panel controls. I believe it was relocated to behind the glove box near the cabin air filter on the Gen-III. Sounds like it's time to power cycle it and see if it recovers.
 
  • Like
Reactions: Old Crows

·
Registered
Joined
·
152 Posts
Discussion Starter #3
On the Gen-II the AC Amplifier was behind the front panel controls. I believe it was relocated to behind the glove box near the cabin air filter on the Gen-III. Sounds like it's time to power cycle it and see if it recovers.
Fibber, thanks Bud! That is good to know. I'm going to take it to Boerne Toy store this week. Can't afford to spend hours tracking the problem down and locating the part locally. Still a good idea to "know" possible solution before I go. The van hasn't cost me anything in 4+ years other than oil, filter and tires and at 51K I`m ahead in this game.

Kind of a strange failure. Thinking back on it, we made 2 trips to San Antone last week. Weather was cool,cold and blustery so the AC wasn't working hard. I noticed that the RECIRC wasn't coming on automatically. It ALWAYS comes on 98% of the time. Strange, I thought... it is suddenly working like a "real" car...... probably the first symptom of impending failure.

I'll report in when it is fixed...

Cheers Mate!
 
  • Like
Reactions: sunshinewr

·
Registered
Joined
·
152 Posts
Discussion Starter #4
Sometimes......

the blind monkey catches a banana!

Fibber, Following up here. I took the van to Boerne Toy store this AM. The "new" Lad (always a new service writer) took my info and info about the problem. We went out to the van so he could just verify a few things. He started it up and cycled the HAVAC on & off. Yep... the front is not working. The rear HVAC IS working. ????? So he began to push the various control buttons for the front system .... nothing..... until he got to the SYNC button and punched it a couple times. SHAZAAAAAAMMMM! The display came up. The temperatures appeared. The twirly knob took control again and the settings changed as they should. Everything was up and running. Diagnosis: The SYNC button has gotten stuck or was in a twilight zone. Once it was punched in everything began to work.

No charge. No rental. Free cup of coffee for the ride home!!!!

Thanks for the suggestion.....again.
 
  • Like
Reactions: fibber2

·
Super Moderator
Joined
·
5,018 Posts
Buy the new kid a 6 pack of his favorite brew for getting up from the writers desk and attempting to verify your complaint!

Something to remember for the future...
 

·
Premium Member
Joined
·
856 Posts
Buy the new kid a 6 pack of his favorite brew for getting up from the writers desk and attempting to verify your complaint!

Something to remember for the future...
I completely agree (hoping that he drinks ;)

A super review will go a long way for him.
 

·
Registered
Joined
·
152 Posts
Discussion Starter #8
Gonna send a favorable communication to Boerne Toyota management!
 
1 - 8 of 8 Posts
Top