Toyota Sienna Forum - siennachat.com banner
1 - 10 of 10 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter · #1 ·
Hello my 2007 scienna le has 155k miles.
Check engine light came one and codes are for trans sensor( shifting funny between 2-3) and not really going into over drive at higher speed
We don't hamner it
Oreilly want 185 for the sensor. Anything I should check before I drop that much coin on it
Van in a fwd
Thanks
 

·
Registered
Joined
·
439 Posts
ATF is at spec level at operating temperature? No coolant in ATF or ATF in coolant?

Would be useful to have the specific code. When you clear the code, does it come back immediately or the first time shifts 2 to 3, or does it take a bunch of driving for the code to return?

Sixto
‘04 LE FWD 198K miles
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #6 ·
Hello
Codes are p 0793 intermediate shaft speed sensor
P 0328 knock sensor 1 circuit high input
The trans is about 1 cm over full hot
Light does not stay on if vehicle sits for a day.
Yesterday it came on when I had to hit the gas to get out of the way.
The air filter was very dirty so I repkaced it but light was still on
Thank you again
 

·
Registered
'04 XLE-L 2WD
Joined
·
1,131 Posts
...my 2007 scienna le has 155k miles.
Check engine light came one and codes are for trans sensor( shifting funny between 2-3) and not really going into over drive at higher speed
Has the trans fluid ever been drained and refilled? Has the trans filter ever been replaced? If not, you may want to replace the filter, refill, and do a couple more drain plug spill & fills a hundred or more miles apart, see if the funny shifting and trans code goes away.
 

·
Registered
Joined
·
1,113 Posts
I would look very close to the wiring and look for rodent damage. Mice damage. In and around the top of the transmission.
You have 2 different codes that are very separate. 1 being the transmission code and 1 being the knock sensor code.
I think the knock sensor code will prevent the trans going into overdrive on the 2007. I know 100% it will on the 2004 as I had that code. Code high means 'open'
 

·
Registered
Joined
·
16 Posts
Discussion Starter · #10 ·
I think i may have found knock code reason. The vac hoses going airbox were routed incorrectly, the t connector was missing and 1 vac box port has no hose on it. The p.o. must of don't this.
I broke the radiator neck nipple that goes to the engine. Got the repair kit from atozone
Now I'm down to 1 code
p0793
I've check for chewed wires.
Nope so I'll dig a little more
I did trans fluid and filter today
 
1 - 10 of 10 Posts
Top