Toyota Sienna Forum - siennachat.com banner

1 - 20 of 31 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
I have a 2007 Sienna.

A couple of days ago the Navigation system stopped working. It would come on for a little while . . .then stop working . .. then come on for a short while . . .then stop working again. It has been intermittent. My mechanic says there are no loose wiring connections and that it's the unit. I trust this guy but I went looking for other advice. It has been suggested that maybe it's the power supply.

Before I go and try to replace the unit, I'd like to make sure what the problem is. It's important not only for the GPS but it has the radio, CD and phone which I like.

Does anyone have a similar experience with the Navigation system cutting out intermittently? Any advice would be appreciated.

Thanks,

ADF
 

·
Registered
Joined
·
378 Posts
well stopped working is an opem desciption. does it balck out or does it stop updating and shows you are stopped? The factory NAV has a dead recogning systems for when you are in a tunnel so if the unit stops displaying or does not show you are moving you are probably looking at an internal error. Since it does work then stops I would guess a thermal issue, has it been really hot. How did your mechanic determine there are no loose wires did he pull the unit out and put it back in? I know it is hot in most places. I would see if it does work at night when it is cooler for a longer period of time than whe the car is hottest at noon when the car has been closed. that will show it is a thermal issue and give you a place to start looking. you can get cans that provide cold to check for thermal issues. are you past your warranty by a lot?

You might be able to find a nav unit at a salvage yard.

Also does the rest of the radio cd work, did you do any aftermarket mods to the car? There is the speed sensor that turns off th ability to use theNAv while moving and it may well be part of the dead recogning system then there is the antenna.

please provide a little more info on the meaning of stops working? does the whole radio stop working or does your position on the map freeze, can you go into the map and zoom etc../
 

·
Premium Member
Joined
·
108 Posts
Have you taken the disc out and cleaned it? The player should be under the front pass. seat accessible from the rear with the front seat all the way forward.. Maybe there is some dirt on it? ???



EDIT: NOTE: the NAV system DVD-player is located under the front passenger's seat ONLY on 2004 models with the factory NAV option. The 2004 had a 2-piece system. Later Siennas have 1-piece all-in-the-dash NAV systems.
BY: topspy/Mod-Squad
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
thanks for the feedback thus far. i will elaborate further.

1. when i refer to the navigation system, i also mean the phone, radio, cd player, gps and reverse camera.
2. the screen is blank and there is no audio.
3. the odd time the screen will re-appear showing the standard warning and the radio comes on. this would last about one minute and then . . .NOTHING . . no more screen, no more audio.
4. there were no after-market mods.
5. the mechanic checked all the cables connecting into the unit.
6. the vehicle is a little over 3 years old and it's outside warranty by a little, but not much.

i will have a look at the DVD on the outside chance that it is dirty. possibly this might help.

thanks again.

adf
 

·
Premium Member
Joined
·
108 Posts
OK... it sounds like a bad connection , ground or pos. I can't upload the grounding page, but maybe someone can. If you can Get a wiring diagram of that circuit or circuits start at the pos side and go through every connection and ground for that circuit including the fuseblock wiggling every wire, but waiting a few seconds for the unit to power-up. Does it do it when the motor is not off also? I doubt that it's internal but it maybe. Electrical problems are a #***$$ but are more easily found when not working.
Does it happen eg; when you go over a bump, have a passenger on the pass seat, hi humidity outside, turn something else on, stereo up loud?
If it is internal you will have steady power at connector for the unit.
Also what is the condition of your battery and alternator? If you are producing less than 13.8 volts your alt maybe going. If your van has been sitting for about an hour, check the volts across the battery terminals. It should be over 12 volts and holding steady, but if the volts are dropping slowly (eg .01 volt every two seconds ) the battery maybe going.
Electronics do not like lower voltage and have strange symptoms.
I hope this helps Colin
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
recent update . . .

i took it somewhere for a second opinion. the electrical specialiast thinks it could be the onboard computer. i'm taking it in later this week and leaving it at the shop for the day so he can take out the computer and work on it in his lab. he has seen this on Honda's and Infiniti's before.

will let you know what i hear.

adf
 

·
Registered
Joined
·
3 Posts
Did you ever get it figured? I have the same problem by the sounds of it, only mine doesn't come on and off. (well it did once after about a month after it stopped working). My screen is black and nothing works. At first I could hear clicking like it was loading CDs or something. The button backlighting would come on and off about every 5 seconds.

I took it to a factory stereo/navigation repair shop and they told me they cannot fix it. They said they had about 5 of them come in over the past three months (which suprises me there are not more complaints or answers on the forum). He said it is a problem with a chip on the main board which they narrowed down on the first one they got. He said Denso (the co. that makes the unit) will not sell them the chip or they would be able to repair the unit for under $300.

Frustraited I send an email to the president of Denso about the issue and asking for them to sell the part to the shop so I could get it repaired rather then shell out the $$$ for a new one. I only recieved an automated responce and not help.

I'm very upset with the quality of my Sienna since I'm facing over $4,500 in repairs for the luxury stuff. 2006 with 65K on the clock shouldn't have that many problems and of course it's out of warranty.

I did find a company in Southern California (http://www.hitechserv.com/) They told me there is a 70% chance based off of my description that they could fix it. I have yet to decide what I want to do with it. I came here to see if anyone here had any answers but this is the only thread I have found even discussing a navigation problem like mine.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #8
Hi Sacto,

I was told by my garage guy that he was 80% confident they could fix the problem. The techie had done this sort of thing before with other makes (Honda etc) so he didn't see too much of a problem.
They soon discovered that the problem was a power supply which came down to a chip being replaced . .. .lo and behold . . it's proprietary and so simply removing the part and soldering a new one on was not going to happen.
The garage had to get a whole new unit from Toyota . . end of story.
The vehicle I bought in 2009 was a 'gently-used' 2007 modle with 120,000 km and of course, like yours, was not covered by any warranty.
You don't know how much you miss it until the radio comes back on. I was without it for two weeks and I had withdrawl ... .I really like the toys on that thing.
Email me direct if you need to discuss further.

ADF
 

·
Premium Member
Joined
·
2,166 Posts
All of you should write MANY nastygrams to Toyota Corp.....and Denso Corp.
Sorry about the NAV/stereo system doorstops. :'( :'( :'( :mad: :mad: :mad:
 

·
Registered
Joined
·
1 Posts
I have a 2005 XLE Limited and the Nav unit has quit working. The screen itself still has lights and power when I adjust the screen settings, radio etc. The nav display just reads to insert disc. It started off this way, and then shortly after that the back up camera quit working. I have had it into 2 shops to have it looked at (very limited expertise where we live, but there is a Toyota dealer)

Before we have to bite the bullet and buy a new one, I would like to explore some options. ??? Is there any way to "reset" the unit? It still plays a cd fine.

Any suggestions are greatly appreciated.

Thanks ;)
 

·
Registered
Joined
·
39 Posts
Our Nav unit along with the cd player stopped working in our '06 Limited and Toyota replaced the whole unit. Lucky it was under warranty because it was expensive to replace.
 

·
Registered
Joined
·
4 Posts
Toyota has a radio/nav exchange program that they don't advertise because they want the customer to pay full boat. If you tell service advisor you want this, they install a refurbished unit and send back your unit to be repaired and for the next guy. The radio replace is about $250 vs $1,800 new. Nav is about $400 vs $3,200 new.
 

·
Registered
Joined
·
1 Posts
I have a 2006 Sienna the navigation/stereo/backup camera sputtered out a lot like the ones described here and now does not work at all. The radio came on and off for a few minutes for a few days, though I could not control it. Now the button back lights on that unit (not the screen) come on and off. I took it in to Toyota today and they could not fix it, said I could get a refurbished one installed for $2900. Any ideas? The car has 106,000 miles.
 

·
Registered
Joined
·
1 Posts
kittymer -- I have the same problem on my 2006 Limited, 85000 miles. When I turn the car on, a message pops up on the screen that says "system loading. Do not turn of the power". Sometimes it comes up, sometimes it doesn't. When it does come up, the radio comes on, but won't stay on consistently -- goes in and out. And the navigation is all messed up (in the few instances where it does come on -- it doesn't stay on long). I'm not an electronics expert, but I'm convninced this isn't a "need a new MAP DVD" issue. There's something failing electronically. I'm fearful that it could be something like others mentioned earlier, like the power supply or something on the motherboard. I'm taking it to the dealer tomorrow to see what they say, but I went to a "Car Toys" store here in the Denver area and tried to describe the problem to them. They don't do repairs, a new in dash Radio / Nav / CD with the rear flip down DVD would cost me around $1700 - $1900 installed, depending on what features I get. Hopefully, the dealer will come up with another alternative (like the refurb option mentioned in one of the earlier posts)

*** Quick update: System has now completely failed, but I was fortunate enough to at least get my Map DVD ejected before it failed. Found a guy in Michigan that does refurbs of these units with a 90 day warranty and a $300 Core Charge (refunded when I send my defective one back). Found him on Ebay under the name toyolexnavspec. Unit should be here soon. Installation should be pretty easy -- youtube videos out there showing how to remove it. It's plug and play, so hopefully I'll be back up and running by Tuesday night... Will update once I get it installed.
 

·
Registered
Joined
·
1 Posts
Hello IKaufman...can you tell me what dealership you went to? I've had the exact same issue as Sacto and the dealership that I visited want to charge $700 for the refurbished unit. Although that is better then the $2300 they told me a new unit would cost I woul like to see if there is another dealer where I can get it for a better price. Thank you!
 

·
Registered
Joined
·
1 Posts
So how much did the ebay guy charge you? I am having the same issues with my 06 model. The dealership says it needs to be replaced to the tune of $3500. I'm fearful if I purchase a used one I will face the same issues.
 

·
Registered
Joined
·
11 Posts
Tomgam,

The DVD/NAV unit in my 2006 Sienna is having the same symptoms that yours had. Did the refurbished unit from toyolexnavspec on eBay work out for you OK?

Regards,
Greg
 

·
Registered
Joined
·
5 Posts
tomgam - any update on the toyolexnavspec ebay experience? Did the one you get work and was it an easy install? I have a 2006 XLE with only 50K miles and it did the same thing (complete fail), mechanic is telling me $4500 for new Toyota unit + install...or a refurbished one for $2900 and I have to send my bad unit back....really hoping to find an alternative...
 
1 - 20 of 31 Posts
Top