Toyota Sienna Forum - siennachat.com banner

1 - 13 of 13 Posts

·
Registered
Joined
·
219 Posts
Discussion Starter #1
Hi!
I just wanted to share with you guys a mod I wanted to do since I got our sienna:
I did not do it before because of the wire splicing and the CK base our sienna uses and the use of resistors.
So basically a few days ago I was looking on amazon for switchback leds and found these:

I ordered a set and plugged it in. worked right away and Im in love with them


Sorry for the potato quality of the video, Im using a loaner phone, Ill upload more pics and video once I get a chance

BTW: Im not paid for reviewing the item, I did not get it free or anything else... Im just sharing my honest review.

This is a mod I highly recommend
 

·
Registered
Joined
·
900 Posts
Good find and thanks for sharing. You may need to specify that this only work for XLE, LE 2011-2019 and 2011-2014 LTD and SE. The 2015 and up SE and LTD has dedicated turn signal wiring and the switchback function will not work with these bulbs except for turn signal only.
 

·
Registered
Joined
·
26 Posts
Been looking for something like this for my 2011 XLE. Reviews say its super easy to install. I’m not extremely mechanically inclined but can “figure things out.” What’s the time under the hood and is it really easy as it seems?
 

·
Registered
Joined
·
219 Posts
Discussion Starter #6
Been looking for something like this for my 2011 XLE. Reviews say its super easy to install. I’m not extremely mechanically inclined but can “figure things out.” What’s the time under the hood and is it really easy as it seems?
SUUUUUUUUUUPER easy, it wont take more than 5 minutes to install
 

·
Registered
Joined
·
26 Posts
following up....as advertised, super easy to install. not as bright as i had hoped but the LED adds some 2017 modern to the 2011 front end and does give off some nice white light. worth $30 for sure, i need to figure out how to secure the heat sinks but so far they aren't rattling around the engine bay that i can tell.
 

·
Registered
Joined
·
219 Posts
Discussion Starter #9 (Edited)
TBH, mine just "float around" since they dont touch anything and I have left them on for more than 5 minutes and never get hot
 

·
Registered
Joined
·
26 Posts
Ya I wound up just tucking them in. Funny though, I had to get my auto start module reprogrammed after installing the switchbacks. Have had the module fine for near 10 years. Not sure if it was them but it cost me $75 :(
 

·
Registered
Joined
·
219 Posts
Discussion Starter #12
Ya I wound up just tucking them in. Funny though, I had to get my auto start module reprogrammed after installing the switchbacks. Have had the module fine for near 10 years. Not sure if it was them but it cost me $75 :(
its really weird since they just act like a regular bulb... I dont see how one is related to the other, but weird things happen with electronic stuff
anyways, glad you liked them
 
1 - 13 of 13 Posts
Top