Toyota Sienna Forum - siennachat.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter #1
Been dealing with a left rear wheel/brake problem that randomly appears then disappears. Without applying brake, left rear wheel shudders like the brake pad is engaging and releasing repeatedly causing a shuddering sensation. More noticeable when braking. Can last a few minutes to 4 or more miles. Stopping for 30+ minutes usually cures the problem until the next random occurrence. Brake rotor/caliper/pad system has been thoroughly analyzed and even replaced components to no avail. Any chance its the ABS system going rogue? Should I start by replacing the wheel speed sensor? Had this 2006 since day 1 and want to keep it but cant trust it now.
 

·
Registered
Joined
·
348 Posts
I assume you have disc brakes? Was this after you had the brakes worked on?

It could be a bad caliper. The piston may be stuck.

Do the slide pins have grease?

Bent wheel or out of balance tire? Have you tried switching wheels?
 

·
Registered
Joined
·
108 Posts
Discussion Starter #3
I assume you have disc brakes? Was this after you had the brakes worked on?

It could be a bad caliper. The piston may be stuck.

Do the slide pins have grease?

Bent wheel or out of balance tire? Have you tried switching wheels?
Disc yes. All components have been disassembled and checked and reinstalled. No connection with last brake service .I'm getting professional help and so far they are stumped too. Current suspects...ABS computer and speed sensor.
 
1 - 3 of 3 Posts
Top